Cómo Utilizar Excel ISERROR Función? [3 ejemplos fáciles]

La función ISERROR de Excel forma parte de la categoría Funciones de información. Si el valor proporcionado representa un error, la función devolverá VERDADERO; de lo contrario, devolverá FALSO. #NAME?, #NUM!, #N/A,  #REF!, #VALUE!, #DIV/0!, or #NULL son todos errores válidos.

La función ISERROR en Excel se usa junto con la función IF para detectar un posible error de fórmula y mostrar otras fórmulas o cadenas de texto como mensajes o espacios en blanco. Si se detecta un error, también se puede utilizar con la función IF para mostrar un mensaje personalizado o realizar algún otro cálculo.

Debemos tratar con algoritmos y datos en el análisis financiero. Nuestra hoja de cálculo tiene con frecuencia una gran cantidad de fórmulas y no siempre se comportan como se espera.

Fórmula: =ISERROR(valor)

La función ISERROR en Excel  aplica el argumento como se muestra a continuación:

Valor: esta es la celda de destino que desea probar. Se proporciona principalmente como una dirección de la celda.

Por lo tanto, desplácese rápidamente hacia abajo hasta esta publicación para aprender a usar la función ESERROR de Excel …

¿Cómo usar la función de Excel ISERROR?

Considere los siguientes escenarios para comprender mejor la función ESERROR de Excel :

Ejemplo 1:

Veamos el resultado de la función cuando enviamos la siguiente información:

Función ESERROR de Excel

Ejemplo 2:

Podemos utilizar la función ISERROR envuelta en la función SUMPRODUCT para contar la cantidad de celdas con errores.

Digamos que nos dan la siguiente información:

Función ESERROR envuelta en la función SUMAPRODUCTO

Usando la fórmula =SUMPRODUCT(–ISERROR(G22:CH27)) , podemos obtener el recuento de celdas con error, como se muestra a continuación.

=SUMAPRODUCTO(–ESERROR(G22:CH27))

En la fórmula anterior:

La función SUMPRODUCT aceptó una o más matrices y calculó la suma de los productos de los números correspondientes.

ISERROR ahora evalúa cada una de las celdas en el rango dado. El resultado será VERDADERO, FALSO, FALSO, FALSO, VERDADERO, VERDADERO, FALSO, VERDADERO, VERDADERO, VERDADERO, FALSO, FALSO.

Como usamos doble unario, los resultados VERDADERO/FALSO se transformaron en 0 y 1. Hizo que los resultados se vieran como {0,1,1,1,0,0,1,0,0,0,1,1}.

SUMPRODUCT ahora suma los elementos de la matriz dada y devuelve el total, que, en el ejemplo, es el número 6.

Como alternativa, se puede utilizar la función SUMA. La fórmula a utilizar será =SUMA(–ISERROR(rango)). Recuerda poner la fórmula en una matriz. Para la matriz, debemos presionar Control + Shift + Enter en lugar de solo Enter.

Ejemplo 3:

Aquí, en este caso, veremos, por ejemplo, si deseamos proporcionar un mensaje personalizado, por ejemplo, en lugar de obtener el error #DIV/0 , queremos que el valor sea 0. Podemos usar la fórmula =SI(ISERROR(A4/ B4), 0, A4/B4) en lugar de A4/B4.

Supongamos que nos dan los siguientes datos:

error #DIV/0

En lugar de VERDADERO , si queremos ingresar el valor 0, la fórmula a utilizar será =SI(ISERROR(B6),0,B6) y no B6, como se muestra a continuación:

=SI(ESERROR(B6),0,B6)

Obtenemos el resultado a continuación como se muestra:

Utilice las funciones de Excel SI ERROR

Método para reemplazar manualmente los valores de ISERROR

Sin embargo, podemos usar la fórmula ISERROR para reemplazar el error; hay un enfoque manual para hacerlo: el método de descubrimiento y reemplazo.

  1. Después de aplicar la fórmula, copie y pegue solo los valores.
  2. Para abrir el cuadro de reemplazo , presione Ctrl + H y escriba el valor del error (#N/A, #DIV/0!, etc.). Tome nota del tipo de error que desea reemplazar.
  3. Sustituya “Datos no encontrados” por el reemplazo con valores.
  4. Seleccione Reemplazar todo en el menú desplegable.

Todos los valores de error especificados anteriormente se reemplazarán con Datos no encontrados como resultado de esto.

Nota: Si ha aplicado un filtro, se debe utilizar la técnica de celdas visibles únicamente para reemplazarlos.

Cosas a tener en cuenta:

La función ISERROR de Excel puede embellecer sus informes numéricos eliminando todo tipo de errores. Si los datos contienen un tipo de error y se utilizan tablas dinámicas, el error también aparecerá en la tabla dinámica. Al detectar valores erróneos, ISERROR puede mejorar la apariencia del informe y evitarle situaciones embarazosas. Solo una celda puede verse afectada por ISERROR a la vez. No puede tomar muchos rangos de celdas. Cuando se aplica a un rango de celdas, solo se tiene en cuenta la primera celda del rango.

Aparte de esto, si tiene algún problema relacionado con Excel, le recomiendo que descargue la poderosa  Excel Reparación herramienta. Esta herramienta avanzada puede corregir todos sus   errores  y problemas de corrupción de Excel . No solo esta herramienta también puede restaurar fórmulas, gráficos, tablas, hojas de gráficos, filtros, clasificaciones, comentarios de celdas.

Si tiene alguna consulta relacionada con este tema, compártala con nosotros en nuestra página oficial de  Facebook  y  Twitter  y no olvide hacer clic en Me gusta y compartir esta publicación con sus amigos…

Buena suerte….



Margret Arthur es emprendedora y experta en marketing de contenidos. Ella Escribe blogs de tecnología y experiencia en MS Office, Excel y otros temas tecnológicos. Her arte distintivo de presentar información técnica en un lenguaje fácil de entender es muy impresionante. Cuando ella no escribe, ella ama los viajes no planificados.